$re = '/^.*?(?=-)/m';
$str = '360i|6cfd596e-2f2f-4d4d-9b2c-33049761f7d6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);