$re = '/(\S+)=(?\'enclosure\'[\"\'])?((?:.(?!(?P=enclosure)?\s+(?:\S+)=|\s*\/?(?P=enclosure)))+.)(?P=enclosure)?/m';
$str = ' align="centered" align="cent\'ered" align=\'cente"red\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);