$re = '/(\@\w+)/';
$str = 'not(CreatedBy eq @me)
CreatedBy eq @me
@me = you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);