use strict;
my $str = '[
{"FILENAME":"/gs/mm-camera-pics/IQ/clark_retasia_ds_df/LX0A3B0143/IMG_20150928_210848118.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVxelZDdk9MbURfT3BWM2Foay1LUWNhcUdRZUpPM1Izak9CUkpBMGZNWGU5NEJVUWZpbmxkbVFQQ3NGLU1USF9XTEFZN3R3MnhUZHc1SzRQWlZURnVuUHlwQko3Zy41MTE1blJ6SnhMMS1SS3JM"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_195315111.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVvWGRlREo3a2xfTF9lUUhaZUltUWNna09qaVlkeWVtSGlhcDh6RXZGeHQ1SzVvd2hhTUhPQ28yTkpvSml5SU43MVlzQTNudEw1dTl4Q3hoa3ZuNUVjNFVtenNJZy5oTXlkcm5IMTJTdUxPaWlz"},
{"FILENAME":"/gs/mm-camera-pics/IQ/clark_retasia_ds_df/LX0A3B0143/IMG_20150928_204536530.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVyX3hnaENKWmdmRGs5SXVaQk5jWUhtelZaWXVtT3VzeXpKSE41ZVF2d3VUQ3I1N3lRSHF5ZDF3aXg1bm51U1QyTmMyUHBFVGYzTzhwQXlKTFV1SFNtRFJNUlZSUS45MG1ZRnVDUks2WDJNb0w1"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_195423777.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVvNVl3cXZjQmNBSHowVW83SVVyVzYtM0hDOUhCS3hYandVWkVTYUNaTkViUHdYSHVRVFRHQzNsNWhhVEZrVzQtTThnZTJwb05HVVI2ZFA5aFh0ck82ZlFXQjluUS5pM2FldmFFRkJ2bWR3cGJu"},
{"FILENAME":"/gs/mm-camera-pics/IQ/clark_retasia_ds_df/LX0A3B0143/IMG_20150928_204725016.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVvQWdvYmJBYlM1am9ZWU1nOHdPYnZEUWFlTEk3cC1uTmxmRF9PMHhBM0ZDRjByNy1WMTc1QUlXbi1TN3I2MjFFSlBERWpJbWdkMnYyOVpQdFlrM183OUJrWG1IUS5GVVhoX3lVTGJtMmNYZEVM"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_210737525.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVxV1RWTjBxSlNPT1VCejc5eXk0R0xuUElFYlRfX25OQTdLcHZoUk44MWZpTnR2TW1aSldLTHlOeDFXeVZOY0Y2c2kzNmIxZ2Q5RGE0Zm9mTGZkSWJIa1VOdUFiQS5nWDZFMk9MZTdsN0tpeGJN"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_185044623.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVvZzFIY1Bub0ZjNW0xdEx0M3gyd2xIcUVYUVBhT3VLOXlpVEVsYTVVQTdWRDdWS3RuRUU2TVhTWXJZN1pORE5ScXFGZHY3bi1kSmFCZ0t4eDItblFVbTBSVHFHUS56amIyUTRPY3FYZnhyVmZZ"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_184936345.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVxS0hlV3lUSnpkYTZFWGRManZUWXoyNmRVTkFwUFlEU2ExTnZXSmFScUhPOHRLX3NVek53WWZCMGhwbUc5bk55eDEwNFdsY3RxTGpXV3BIV293U0d6cDFiakxvZy5pSmowNjFtWWFQQ2kxSDVy"},
{"FILENAME":"/gs/mm-camera-pics/IQ/clark_retasia_ds_df/LX0A3B0143/IMG_20150928_210850868.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVxaklHS3BKN1F3VUt1NWhqUkZ5ekU0cXFyQVAwNEc3TGZqSVd2c19WeDMxYk1vazVoVzhSVy1vVXdxMFE1c2ZWWS14VDlhVXp4S1N6dElsMW5YcldOYnBtckx5QS5rZEdWRUx2YjJuRXZOTlh3"},
{"FILENAME":"/gs/mm-camera-pics/IQ/merlin_retasia/NCFP130133/IMG_20150928_195420733.jpg/L2FwcGhvc3RpbmdfcHJvZC9ibG9icy9BRW5CMlVwRUNaanhBVnMtVDFwbFhoeUNEcGhJbEhsMWk1VWtPUlJyX2hETWxJRGhUbFF4dTh5SVlac0pnaUV6cTFsWjZFaHVuRC1qWWxSWE8wV2pVSzFfNUhodk0xazBwUS4taE5Cc1FFdnRKTDFtaWMz"}
]';
my $regex = qr/(?<=gs/).*?(?="})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}