package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(.+)\s(\/.*)\?(.+=.+)+\s(.+)\/(\d\.\d)$\n(^(.+):\s(.*)$\n)*`)
var str = `GET /index.html?x=1&y=2 HTTP/1.1
Host: localhost:8080
Chunked: yes
GET /index.html?x=1&y=2 HTTP/1.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}