$re = '/^(\d{5})(?:-?(\d{4}))?$/';
$str = '90210-1234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);