import Foundation
let pattern = ##"^(https?:\/\/)?(www.)?([\da-zA-z\_\-]+)\.(com|(|[\da-zA-Z]{2,6}))([\/\w \.\-\#\&\?\%\_]*)?([^\/| |\s])$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://regex101.com/
http://regex101.com
http://www.regex101.com/
http://www.regex101.com
https://regex101.com/
https://regex101.com
https://www.regex101.com/
https://www.regex101.com
http://regex101.com/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.com/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.com/blahblahblahblahblah/blahblahblahblahblah
http://regex101.co.uk/
http://regex101.co.uk
http://www.regex101.co.uk/
http://www.regex101.co.uk
https://regex101.co.uk/
https://regex101.co.uk
https://www.regex101.co.uk/
https://www.regex101.co.uk
http://regex101.co.uk/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.co.uk/blahblahblahblahblah/blahblahblahblahblah
http://regex101.de/
http://regex101.de
http://www.regex101.de/
http://www.regex101.de
https://regex101.de/
https://regex101.de
https://www.regex101.de/
https://www.regex101.de
http://regex101.de/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://regex101.de/blahblahblahblahblah/blahblahblahblahblah
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
http://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://regex101.de/blahblahblahblahblah/blahblahblahblahblah
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah/
https://www.regex101.de/blahblahblahblahblah/blahblahblahblahblah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)