$re = '/^1\.?0{0,8}$|^0\.\d{0,8}$/';
$str = '1.000000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);