package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\b(?:[A-Z]\w+\b(?:\s*)?)+$`)
var str = `Naveen Kumar
Naveen kumar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}