$re = '/^\d*\s*[!<>=](?>\=)?\s*\d+$|^\d*\s*<>\d+/m';
$str = '>100
<100
>=100
<=100
=100
!=100
==100
> 100
> 100
!= 100
== 100
100
===100
<<100
=<100
<>100
100 != 100
100 == 100
100 < 99
100 > 99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);