package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\d|\.|\,]+`)
var str = `123,13.45
dfg
12.3
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}