package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)\s-\s(\w*)\s-\s(.*)`)
var str = `PARIS - AGENCE - COFFRE-FORT`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}