#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(t(?:h[uứ])? ?(?:tư|[2-7]|hai|ba|năm|sáu|bảy)|chủ nhật)( *)(?: ?(?:đầu|cuối)? ?(?:tuần (?:trước|sau|này)))?$"
Local $sString = "thứ 2" & @CRLF & _
"thứ 3" & @CRLF & _
"thứ 4" & @CRLF & _
"thứ 5" & @CRLF & _
"thứ 6" & @CRLF & _
"thứ 7" & @CRLF & _
"" & @CRLF & _
"t2" & @CRLF & _
"t3" & @CRLF & _
"t4" & @CRLF & _
"t5" & @CRLF & _
"t6" & @CRLF & _
"t7" & @CRLF & _
"" & @CRLF & _
"thứ hai" & @CRLF & _
"thứ ba" & @CRLF & _
"thứ tư" & @CRLF & _
"" & @CRLF & _
"thứ2" & @CRLF & _
"thứ3" & @CRLF & _
"chủnhật" & @CRLF & _
"Chủ nhật" & @CRLF & _
"" & @CRLF & _
"thứ hai cuối tuần sau" & @CRLF & _
"thứ ba cuối tuần sau" & @CRLF & _
"thứ tư cuối tuần sau" & @CRLF & _
"thứ năm cuối tuần sau" & @CRLF & _
"thứ năm đầu tuần sau" & @CRLF & _
"thứ sáu đầu tuần sau" & @CRLF & _
"thứ bảy tuần sau" & @CRLF & _
"chủ nhật tuần trước" & @CRLF & _
"chủ nhật tuần này" & @CRLF & _
"t8 cuối tuần này" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"thuhai" & @CRLF & _
"thuba" & @CRLF & _
"thutu" & @CRLF & _
"thunam" & @CRLF & _
"tha thu" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")