re = /^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(\.[a-z0-9]{2,4}){1,2}$/m
str = 'khoapd7@fpt.com.vn
new_email@example.com
khoadeptrai_thanhlich_vodich_khapvutru@gmail.com
foo@example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end