// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)a href="([^"]+).*?title="([^"]+).*?src="(.*?)".*?"#).unwrap();
let string = "<div class=\"home_post_cont post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/el-odio-que-das-2018-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/el-odio-que-das-220x320.jpg\" class=\" wp-post-image\" alt=\"El odio que das (2018)\" title=\"El odio que das (2018)\" extract=\"<div class="home_post_content"><div class="in_title">El odio que das (2018)</div><p>La joven Starr es testigo del fatal tiroteo de su mejor amigo Khalil en manos de un oficial de policía. Ahora, con la presión de su comunidad, Starr debe mantener su posición y defender lo ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/crimen/">Crimen</a> / <a href="https://www.cinecalidad.to/genero-peliculas/drama/">Drama</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/el-odio-que-das-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/el-odio-que-das-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/la-ultima-carcajada-2019-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/the-last-laugh-220x320.jpg\" class=\" wp-post-image\" alt=\"La última carcajada (2019)\" title=\"La última carcajada (2019)\" extract=\"<div class="home_post_content"><div class="in_title">La última carcajada (2019)</div><p>Cuando el manager Al Hart se vuelve a encontrar con su primer cliente, Buddy Green, un comediante que salió del negocio hace 50 años, lo convence de escapar de su retiro y viajar a través ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/comedia/">Comedia</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/the-last-laugh-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/the-last-laugh-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont home_post_cont_last post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/fanatico-del-tiempo-2018-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/time-freak-220x320.jpg\" class=\" wp-post-image\" alt=\"Fanático del tiempo (2018)\" title=\"Fanático del tiempo (2018)\" extract=\"<div class="home_post_content"><div class="in_title">Fanático del tiempo (2018)</div><p>Un genio adolescente está enamorado de una chica que termina con él después de un año. Entonces inventa una máquina del tiempo e intenta solucionarlo ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/comedia/">Comedia</a> / <a href="https://www.cinecalidad.to/genero-peliculas/drama/">Drama</a> / <a href="https://www.cinecalidad.to/genero-peliculas/romance/">Romance</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/time-freak-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/time-freak-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/el-primer-hombre-en-la-luna-2018-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/el-primer-hombre-en-la-luna-220x320.jpg\" class=\" wp-post-image\" alt=\"El primer hombre en la Luna (2018)\" title=\"El primer hombre en la Luna (2018)\" extract=\"<div class="home_post_content"><div class="in_title">El primer hombre en la Luna (2018)</div><p>La vida del astronauta Neil Armstrong y la legendaria misión espacial que lo llevó a convertirse en el primer hombre en caminar en la Luna, el 20 de julio de 1969. Títulos:El ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/biografia/">Biografía</a> / <a href="https://www.cinecalidad.to/genero-peliculas/destacada/">Destacada</a> / <a href="https://www.cinecalidad.to/genero-peliculas/drama/">Drama</a> / <a href="https://www.cinecalidad.to/genero-peliculas/historia/">Historia</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/el-primer-hombre-en-la-luna-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/el-primer-hombre-en-la-luna-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/a-ganar-2018-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/a-ganar-220x320.jpg\" class=\" wp-post-image\" alt=\"¡A ganar! (2018)\" title=\"¡A ganar! (2018)\" extract=\"<div class="home_post_content"><div class="in_title">¡A ganar! (2018)</div><p>Después de la trágica muerte de la estrella de volley Caroline Found, un equipo de estudiantes desanimadas debe unirse bajo la guía de su entrenadora con la esperanza de ganar el ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/deporte/">Deporte</a> / <a href="https://www.cinecalidad.to/genero-peliculas/drama/">Drama</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/a-ganar-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/a-ganar-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont home_post_cont_last post_box\"> <a href=\"https://www.cinecalidad.to/pelicula/johnny-english-3-0-2018-online-descarga/\"><img width=\"220\" height=\"320\" src=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/johnny-english-de-nuevo-en-accion-220x320.jpg\" class=\" wp-post-image\" alt=\"Johnny English 3.0 (2018)\" title=\"Johnny English 3.0 (2018)\" extract=\"<div class="home_post_content"><div class="in_title">Johnny English 3.0 (2018)</div><p>Después que un ataque cibernético revele la identidad de todos los agentes de encubierto en Gran Bretaña, Johnny English se ve obligado a salir de su retiro para encontrar al ...</p></div><div class="home_post_cat"><a href="https://www.cinecalidad.to/genero-peliculas/accion/">Acción</a> / <a href="https://www.cinecalidad.to/genero-peliculas/aventura/">Aventura</a> / <a href="https://www.cinecalidad.to/genero-peliculas/comedia/">Comedia</a></div>\" srcset=\"https://www.cinecalidad.to/wp-content/uploads/2019/01/johnny-english-de-nuevo-en-accion-220x320.jpg 220w, https://www.cinecalidad.to/wp-content/uploads/2019/01/johnny-english-de-nuevo-en-accion-103x150.jpg 103w\" sizes=\"(max-width: 220px) 100vw, 220px\" /></a></div><div class=\"home_post_cont post_box\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}