const regex = new RegExp('(?:http(?:s)?:\\/\\/)?(?:(?:www)\\.(?:tiktok\\.com)(?:\\/)(?!foryou)(@[a-zA-z0-9]+)(?:\\/)(?:video)(?:\\/)([\\d]+)|(?:m)\\.(?:tiktok\\.com)(?:\\/)(?!foryou)(?:v)(?:\\/)?(?=([\\d]+)\\.html))', 'gm')
const str = `https://m.tiktok.com/h5/share/usr/6641141594707361797.html
https://www.tiktok.com/embed/6567659045795758085
https://www.tiktok.com/share/user/6567659045795758085
https://www.tiktok.com/trending?shareId=6744531482393545985
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411
https://www.tiktok.com/foryou?is_copy_url=1&is_from_webapp=v1&item_id=7103185591575088411#/@jd77777778/video/7103185591575088411
https://www.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/v/6749869095467945218
https://m.tiktok.com/v/6749869095467945218
https://m.tiktok.com/@cchelseameow/video/6751181801206729990
https://m.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc
https://m.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/@cchelseameow/video/6751181801206729990
https://www.tiktok.com/@jd77777778/video/7103185591575088411?is_from_webapp=1&sender_device=pc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}