$re = '/(?i)SalesExport.*(?=csv$)/m';
$str = 'SalesExportCSV_12282020.CSV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);