package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*)`)
var str = `Sample 2
James B. Lapointe
1481 Keyser Ridge Road
Appartment Keyser Ridge Road
Archdale, NC 27263
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}