import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\D+)?(?:(?:[4-7](?:(?:\\.|\\,)[1-9])?)|(?:[5-8](?:(?:\\.|\\,)0)?))(?:(?:\\s?gb)|\\s?giga|\\sgigabyte)?(?:.*)";
final String string = "4.5 polegadas (~ 64,3% relação tela-corpo)\n\n"
+ "5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
+ "5,5 polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
+ "5\"-6\" polegadas super amoled full hd, 1080p 401 ppi corning® gorilla® glass 3\n\n"
+ "^(?:(6(?:\\.|\\,)0)|(5(?:\\.|\\,)[1-9]))(.*)\n"
+ "\\s?(?:(?:\\d+)(?:\\.|\\,)?(?:\\d+)?)(?:\"|''|\\x60|'|´|”)\n\n"
+ "(?:(5(?:\\.|\\,)0)|(4(?:\\.|\\,)[1-9]))(.*)\n\n"
+ "(4(?:\\.|\\,)[1-9])(.*) => 4-5\n"
+ "(5(?:\\.|\\,)[0]))(.*) => 4-5";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}