using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[\n|\t])*.+?(?:[^;']|(?:'[^']+'))+;$";
string input = @"SELECT * FROM database;
SELECT * FROM database WHERE somefield = 'somevalue';
SELECT * FROM database WHERE somefield = ""somevalue"";
EXPLAIN SELECT * FROM database WHERE somefield = ""somevalue"";
SELECT * FROM database WHERE somefield = 'somevalue' AND someotherfield = 'somemistypedstring;
SELECTing is hard, though, this is just text!;
SELECT
*
FROM
test_table
WHERE
test_row = 'Testing ; semicolon';
SELECT * FROM another_test_table;
INSERT INTO
table_name
VALUES
(value1,'value which contains semicolon ;;;;',value3,...);
WITH JOIN parcels
WHERE sp;
select * from accounts;
select * from events_stages_history;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}