re = /[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Z|a-z]{2,}/m
str = 'test@gmail.com
test+abc@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end