import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z]{2}\\s\\d\\s\\d\\d:[\\d]{2}:[\\d]{2})\\s([\\w]+[\\.][\\w]+)\\s([\\w|=]+)\\[(\\d+)\\]:\\s.+[\\(|\\s|\\\\|\\\"|\\)]";
final String string = "Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)\n"
+ "Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)\n"
+ "Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)\n"
+ "Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)\n"
+ "Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \\\"0xDEADBEEF\\\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}