const regex = /(queryStringParameters=[^&]*&?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(queryStringParameters=[^&]*&?)', 'gm')
const str = `/geoinfo/weather/current/-83.442836,-214.974261?queryStringParameters=dddd&name1=sdasdas&queryStringParameters=2222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}