package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(client|device|simcard)$`)
var str = `simcard`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}