$re = '/(?!^(.)\1{9,}$)(?!^123456789)^[a-zA-Z0-9]{10,}$/m';
$str = '123d456789012d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);