# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Za-z./\-\(\=><) ]+:?\*?|^[A-Za-z./\-\(\=><)0-9 ]+:+?|^[A-Za-z0-9/\-\(]+)? *?(([0-9\*]+)(\.|\-)*([0-9\*]+)*)([a-zA-Z./% ]*) ?([0-9.\-= ]+)? ?(?![0-9]+)([a-zA-Z./% ]+)?$"
test_str = ("Platelet Count : 297 10 ^ 3/c.mm150 - 450\n"
"Total T3 (Tri-iodothyronine) : 86.99 ng/dl 58 - 159\n"
"Bilirubin (Direct) SERUM 0.32 0 - 0.50 mg/dl\n"
"Total Cholesterol SERUM 180.00 0 - 200 mg/dl\n"
"Packed Cell Volume : 39.7 % 36.0 - 46.0\n"
"asd123\n"
"y Q P Age /Sex * 45Years / Female123asd\n"
"Blood Sugar Fasting PLASMA 92 70 - 105 mg/dl\n"
"Referred By : QUANTUM CORPORTAE HEALTH Age /Sex : 32 Years Male\n"
"Packed Cell Volume : 39.7 % 36.0 - 46.0\n"
"Platelet Count : 341 10 * 3/c.mm150 - 400\n"
"Uric Acid SERUM 8.42* 3.50-7.20 mg/dl\n"
"SERUM TOTAL CHOLESTEROL 180 mg/dl 123Desirable\n"
"ESR :* 22 mm / thr. 0-12\n"
"Haemoglobin - 12.4 gm % 12.0 - 15.0\n"
"Erythrocytes : 4.30 mill/c.mm 3.8 - 4.8\n"
"MCHC :* 31.4 g/dl 31.5 - 34.5\n"
"MPV :* 8.7 fl 9.0 - 13.0\n"
"Neutrophils - 62 % 40 - 80\n"
"Eosinophils 4-3 % 1-6\n"
"ABO And RhD Typing : A - positive\n"
"Poikilocytosis 5 *\n"
"Referred By : Quantum Corportae Health Pvt Ltd Ace Sen seme . Yeas. / Female\n\n"
"^([A-Za-z./\\-\\(\\) ]+|^[A-Za-z0-9/\\-\\(]+) +([0-9.\\-]+) *([a-zA-Z/%1 ]*) +([0-9./\\-= ]+)* *([A-Za-z/]*)\n\n\n"
"^([A-Za-z./\\-\\(\\=><) ]+|^[A-Za-z0-9/\\-\\(]+) *([0-9.\\*-]+)([a-zA-Z./% ]*) +([0-9.\\-= ]+)* *([A-Za-z/]*)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.