$re = '/ test(?!.*test)/i';
$str = 'the test a test from test word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);