#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<div class="listing-img-container media-cover text-center">[\s\S]*?src="([^"]+?\.jpg)"
Local $sString = " " & @CRLF & _
" <div class="panel-body panel-card-section">" & @CRLF & _
" <div class="media">" & @CRLF & _
" <a href="/users/show/227945"" & @CRLF & _
" class="pull-right media-photo media-round card-profile-picture card-profile-picture-offset">" & @CRLF & _
" <img src="https://a0.muscache.com/ic/users/227945/profile_pic/1388936013/original.jpg?interpolation=lanczos-none&crop=w:w;*,*&crop=h:h;*,*&resize=68:*&output-format=jpg&output-quality=70" alt="">" & @CRLF & _
" </a>" & @CRLF & _
" <a href="/rooms/2945119?s=kOTS" class="text-normal">" & @CRLF & _
" <div title="Design 3BDR Rutera Flat by Old Town" class="h5 listing-name text-truncate row-space-top-1">" & @CRLF & _
" Design 3BDR Rutera Flat by Old Town" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="text-muted listing-location text-truncate"><a href="/rooms/2945119?s=kOTS" class="text-normal link-reset">" & @CRLF & _
" Entire home/apt · 21 reviews · Staré MÄ›sto, Prague" & @CRLF & _
"</a>" & @CRLF & _
"</div>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <div itemscope itemtype="http://schema.org/Enumeration" class="col-6 row-space-1">" & @CRLF & _
" <div data-lat="50.08928960447257"" & @CRLF & _
" data-lng="14.436735694282277"" & @CRLF & _
" data-name="Funky Central Art Apt with Terrace!"" & @CRLF & _
" data-url="/rooms/2688532?s=kOTS"" & @CRLF & _
" data-user="1037514"" & @CRLF & _
" data-id="2688532"" & @CRLF & _
" class="listing"" & @CRLF & _
" itemscope itemtype="http://schema.org/Enumeration">" & @CRLF & _
" " & @CRLF & _
" <div class="panel-image listing-img">" & @CRLF & _
" <a href="/rooms/2688532?s=kOTS" class="media-photo media-cover">" & @CRLF & _
" <div class="listing-img-container media-cover text-center">" & @CRLF & _
" <img src="https://a0.muscache.com/airbnb/static/page3/v3/room_default_no_photos-d10f15172f4bf511e23e152ece74faaa.png" data-current="0" class="img-responsive-height hide" data-urls="["https://a2.muscache.com/ic/pictures/37070267/7555e7e6_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170017/c702a86e_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37070259/4e7ef180_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170032/a0f198c9_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37070286/2fee34b1_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170045/eba1336b_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/37070292/9ee05643_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170058/b9dc763d_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/37070298/cac270ba_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170068/abed8d24_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/37070305/77f5021f_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/35170087/0fae08f3_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/37070312/70835c4f_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/35170102/4290046e_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/37070326/14068f20_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/35170261/13b250d4_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/37070330/79e9df48_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170214/bb9ecd68_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37070341/bf823f1b_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35169982/0629a75b_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/37070352/cdf837f3_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170120/9e97e996_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37070369/99ac0d0a_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/35170137/d0623b29_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37071083/b7f61b16_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170162/6ce820a7_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/37071085/6d33eb21_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170183/c0016f10_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37071088/42fafbe0_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170201/a196880c_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/37071098/7ad08efd_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170299/aac56da5_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/37071881/3a0a19ea_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a0.muscache.com/ic/pictures/35170277/17580bf8_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a2.muscache.com/ic/pictures/35170227/73939649_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70", "https://a1.muscache.com/ic/pictures/35170249/9d975bfb_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"]">" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" " & @CRLF & _
" <div class="target-prev target-control block-link">" & @CRLF & _
" <i class="icon icon-chevron-left icon-size-2 icon-white"></i>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <a class="target-details block-link" & @CRLF & _
" "" & @CRLF & _
" href="/rooms/2688532?s=kOTS"></a>" & @CRLF & _
" " & @CRLF & _
" <div class="panel-overlay-bottom-left panel-overlay-label panel-overlay-listing-label">" & @CRLF & _
" <div>" & @CRLF & _
" <sup class="h6 text-contrast">Kč</sup>" & @CRLF & _
" <span class="h3 price-amount">1007</span>" & @CRLF & _
" <sup class="h6 text-contrast"></sup>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="target-next target-control block-link">" & @CRLF & _
" <i class="icon icon-chevron-right icon-size-2 icon-white"></i>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="panel-overlay-top-right wl-social-connection-panel">" & @CRLF & _
" <span class="rich-toggle wish_list_button wishlist-button"" & @CRLF & _
" data-img="https://a2.muscache.com/ic/pictures/37070267/7555e7e6_original.jpg?interpolation=lanczos-none&size=x_medium&output-format=jpg&output-quality=70"" & @CRLF & _
" data-name="Funky Central Art Apt with Terrace!"" & @CRLF & _
" data-address="Josefov, Prague"" & @CRLF & _
" data-hosting_id="2688532">" & @CRLF & _
" <input type="checkbox"" & @CRLF & _
" id="wishlist-widget-2688532"" & @CRLF & _
" name="wishlist-widget-2688532"" & @CRLF & _
" data-for-hosting="2688532">" & @CRLF & _
" <label for="wishlist-widget-2688532">" & @CRLF & _
" <i class="icon icon-heart icon-pink icon-rausch icon-size-2 rich-toggle-checked"></i>" & @CRLF & _
" <i class="icon icon-heart wishlist-heart-unchecked icon-size-2 rich-toggle-unchecked"></i>" & @CRLF & _
" <i class="icon icon-heart-alt icon-white icon-size-2"></i>" & @CRLF & _
" </label>" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="panel-body panel-card-section">" & @CRLF & _
" <div class="media">" & @CRLF & _
" <a href="/users/show/1037514"" & @CRLF & _
" class="pull-right media-photo media-round card-profile-picture card-profile-picture-offset">" & @CRLF & _
" <img src="https://a0.muscache.com/ic/users/1037514/profile_pic/1360186418/original.jpg?interpolation=lanczos-none&crop=w:w;*,*&crop=h:h;*,*&resize=68:*&output-format=jpg&output-quality=70" alt="">" & @CRLF & _
" </a>" & @CRLF & _
" <a href="/rooms/2688532?s=kOTS" class="text-normal">" & @CRLF & _
" <div title="Funky Central Art Apt with Terrace!" class="h5 listing-name text-truncate row-space-top-1">" & @CRLF & _
" Funky Central Art Apt with Terrace!" & @CRLF & _
" </div>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="text-muted listing-location text-truncate"><a href="/rooms/2688532?s=kOTS" class="text-normal link-reset">" & @CRLF & _
" Entire home/apt · 38 reviews · Josefov, Prague" & @CRLF & _
"</a>" & @CRLF & _
"</div>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")