# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{1,3})(cc|)y\d{1,4}\w(?:[-_](\d{1,3})(cc|)y)?"
test_str = ("DOA000281_ICS_U-M1-1740_R-M1-1740_W.TAB\n"
"DOA000281_ICS_U-M1-1740_R-M200-1740CCU_W.TAB\n"
"DOA000281_ICS_U-M1-1740_R-M200-1740_W.TAB\n"
"DOA000281_ICS_U-M1-1740_R-M30-1740CCU_W.TAB\n"
"DOA000281_ICS_U-M1-300_R-M1-300_S.TAB\n"
"DOA000281_ICS_U-M1-300_R-M200-300CCU_S.TAB\n"
"DOA000281_ICS_U-M1-300_R-M200-300_S.TAB\n"
"DOA000281_ICS_U-M1-300_R-M30-300CCU_S.TAB\n"
"DOA000281_ICS_U-M10-1740_R-M10-1740_W.TAB\n"
"DOA000281_ICS_U-M10-300_R-M10-300_S.TAB\n"
"DOA000281_ICS_U-M2-1740_R-M2-1740_W.TAB\n"
"DOA000281_ICS_U-M2-300_R-M2-300_S.TAB\n"
"DOA000281_ICS_U-M200-1740CCU_R-M1-1740_W.TAB\n"
"DOA000281_ICS_U-M200-1740_R-M1-1740_W.TAB\n"
"DOA000281_ICS_U-M200-300CCU_R-M1-300_S.TAB\n"
"DOA000281_ICS_U-M200-300_R-M1-300_S.TAB\n"
"DOA000281_ICS_U-M30-1740CCU_R-M1-1740_W.TAB\n"
"DOA000281_ICS_U-M30-300CCU_R-M1-300_S.TAB\n"
"DOA000281_ICS_U-M5-1740_R-M5-1740_W.TAB\n"
"DOA000281_ICS_U-M5-1740_R-M50-1740_W.TAB\n"
"DOA000281_ICS_U-M5-300_R-M5-300_S.TAB\n"
"DOA000281_ICS_U-M5-300_R-M50-300_S.TAB\n"
"DOA000281_ICS_U-M50-1740_R-M5-1740_W.TAB\n"
"DOA000281_ICS_U-M50-300_R-M5-300_S.TAB\n"
"DOA_000533_ICS_10y180sMax.tab\n"
"DOA_000533_ICS_10y360wMax.tab\n"
"DOA_000533_ICS_1y180sMax.tab\n"
"DOA_000533_ICS_1y180s_200ccy180sMax.tab\n"
"DOA_000533_ICS_1y180s_200y180sMax.tab\n"
"DOA_000533_ICS_1y180s_30ccy180sMax.tab\n"
"DOA_000533_ICS_1y360wMax.tab\n"
"DOA_000533_ICS_1y360w_200ccy360wMax.tab\n"
"DOA_000533_ICS_1y360w_200y360wMax.tab\n"
"DOA_000533_ICS_1y360w_30ccy360wMax.tab\n"
"DOA_000533_ICS_200ccy180s_1y180sMax.tab\n"
"DOA_000533_ICS_200ccy360w_1y360wMax.tab\n"
"DOA_000533_ICS_200y180s_1y180sMax.tab\n"
"DOA_000533_ICS_200y360w_1y360wMax.tab\n"
"DOA_000533_ICS_2y180sMax.tab\n"
"DOA_000533_ICS_2y360wMax.tab\n"
"DOA_000533_ICS_30ccy180s_1y180sMax.tab\n"
"DOA_000533_ICS_30ccy360w_1y360wMax.tab\n"
"DOA_000533_ICS_50y180s_5y180sMax.tab\n"
"DOA_000533_ICS_50y360w_5y360wMax.tab\n"
"DOA_000533_ICS_5y180sMax.tab\n"
"DOA_000533_ICS_5y180s_50y180sMax.tab\n"
"DOA_000533_ICS_5y360wMax.tab\n"
"DOA_000533_ICS_5y360w_50y360wMax.tab\n"
"CFA_AUG2018_2D DOA_000537_ICS_10y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_10y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600s_200ccy600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600s_200y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600s_30ccy600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600w_200ccy600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600w_200y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_1y600w_30ccy600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_200ccy600s_1y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_200ccy600w_1y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_200y600s_1y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_200y600w_1y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_2y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_2y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_30ccy600s_1y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_30ccy600w_1y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_50y600s_5y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_50y600w_5y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_5y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_5y600s_50y600sMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_5y600wMax.TAB\n"
"CFA_AUG2018_2D DOA_000537_ICS_5y600w_50y600wMax.TAB\n"
"DOA000557_ICS_U-M1-300_R-M1-300_W_2D.TAB\n"
"DOA000557_ICS_U-M1-300_R-M200-300CCU_W_2D.TAB\n"
"DOA000557_ICS_U-M1-300_R-M200-300_W_2D.TAB\n"
"DOA000557_ICS_U-M1-300_R-M30-300CCU_W_2D.TAB\n"
"DOA000557_ICS_U-M1-60_R-M1-60_S_2D.TAB\n"
"DOA000557_ICS_U-M1-60_R-M200-60CCU_S_2D.TAB\n"
"DOA000557_ICS_U-M1-60_R-M200-60_S_2D.TAB\n"
"DOA000557_ICS_U-M1-60_R-M30-60CCU_S_2D.TAB\n"
"DOA000557_ICS_U-M10-300_R-M10-300_W_2D.TAB\n"
"DOA000557_ICS_U-M10-60_R-M10-60_S_2D.TAB\n"
"DOA000557_ICS_U-M2-300_R-M2-300_W_2D.TAB\n"
"DOA000557_ICS_U-M2-60_R-M2-60_S_2D.TAB\n"
"DOA000557_ICS_U-M200-300CCU_R-M1-300_W_2D.TAB\n"
"DOA000557_ICS_U-M200-300_R-M1-300_W_2D.TAB\n"
"DOA000557_ICS_U-M200-60CCU_R-M1-60_S_2D.TAB\n"
"DOA000557_ICS_U-M200-60_R-M1-60_S_2D.TAB\n"
"DOA000557_ICS_U-M30-300CCU_R-M1-300_W_2D.TAB\n"
"DOA000557_ICS_U-M30-60CCU_R-M1-60_S_2D.TAB\n"
"DOA000557_ICS_U-M5-300_R-M5-300_W_2D.TAB\n"
"DOA000557_ICS_U-M5-300_R-M50-300_W_2D.TAB\n"
"DOA000557_ICS_U-M5-60_R-M5-60_S_2D.TAB\n"
"DOA000557_ICS_U-M5-60_R-M50-60_S_2D.TAB\n"
"DOA000557_ICS_U-M50-300_R-M5-300_W_2D.TAB\n"
"DOA000557_ICS_U-M50-60_R-M5-60_S_2D.TAB\n"
"DOA000616_617 ICS U-M1-300_R-M1-300_Winter.TAB\n"
"DOA000616_617 ICS U-M1-300_R-M200-300CCU_Winter.TAB\n"
"DOA000616_617 ICS U-M1-300_R-M200-300_Winter.TAB\n"
"DOA000616_617 ICS U-M1-300_R-M30-300CCU_Winter.TAB\n"
"DOA000616_617 ICS U-M1-60_R-M1-60_Summer.TAB\n"
"DOA000616_617 ICS U-M1-60_R-M200-60CCU_Summer.TAB\n"
"DOA000616_617 ICS U-M1-60_R-M200-60_Summer.TAB\n"
"DOA000616_617 ICS U-M1-60_R-M30-60CCU_Summer.TAB\n"
"DOA000616_617 ICS U-M10-300_R-M10-300_Winter.TAB\n"
"DOA000616_617 ICS U-M10-60_R-M10-60_Summer.TAB\n"
"DOA000616_617 ICS U-M2-300_R-M2-300_Winter.TAB\n"
"DOA000616_617 ICS U-M2-60_R-M2-60_Summer.TAB\n"
"DOA000616_617 ICS U-M200-300CCU_R-M1-300_Winter.TAB\n"
"DOA000616_617 ICS U-M200-300_R-M1-300_Winter.TAB\n"
"DOA000616_617 ICS U-M200-60CCU_R-M1-60_Summer.TAB\n"
"DOA000616_617 ICS U-M200-60_R-M1-60_Summer.TAB\n"
"DOA000616_617 ICS U-M30-300CCU_R-M1-300_Winter.TAB\n"
"DOA000616_617 ICS U-M30-60CCU_R-M1-60_Summer.TAB\n"
"DOA000616_617 ICS U-M5-300_R-M5-300_Winter.TAB\n"
"DOA000616_617 ICS U-M5-300_R-M50-300_Winter.TAB\n"
"DOA000616_617 ICS U-M5-60_R-M5-60_Summer.TAB\n"
"DOA000616_617 ICS U-M5-60_R-M50-60_Summer.TAB\n"
"DOA000616_617 ICS U-M50-300_R-M5-300_Winter.TAB\n"
"DOA000616_617 ICS U-M50-60_R-M5-60_Summer.TAB\n"
"DOA000674_ICS_U_M10_120_R_M10_120_S.TAB\n"
"DOA000674_ICS_U_M10_600_R_M10_600_W.TAB\n"
"DOA000674_ICS_U_M1_120_R_M1_120_S.TAB\n"
"DOA000674_ICS_U_M1_120_R_M200_120CCU_S.TAB\n"
"DOA000674_ICS_U_M1_120_R_M200_120_S.TAB\n"
"DOA000674_ICS_U_M1_120_R_M30_120CCU_S.TAB\n"
"DOA000674_ICS_U_M1_600_R_M1_600_W.TAB\n"
"DOA000674_ICS_U_M1_600_R_M200_600CCU_W.TAB\n"
"DOA000674_ICS_U_M1_600_R_M200_600_W.TAB\n"
"DOA000674_ICS_U_M1_600_R_M30_600CCU_W.TAB\n"
"DOA000674_ICS_U_M200_120CCU_R_M1_120_S.TAB\n"
"DOA000674_ICS_U_M200_120_R_M1_120_S.TAB\n"
"DOA000674_ICS_U_M200_600CCU_R_M1_600_W.TAB\n"
"DOA000674_ICS_U_M200_600_R_M1_600_W.TAB\n"
"DOA000674_ICS_U_M2_120_R_M2_120_S.TAB\n"
"DOA000674_ICS_U_M2_600_R_M2_600_W.TAB\n"
"DOA000674_ICS_U_M30_120CCU_R_M1_120_S.TAB\n"
"DOA000674_ICS_U_M30_600CCU_R_M1_600_W.TAB\n"
"DOA000674_ICS_U_M50_120_R_M5_120_S.TAB\n"
"DOA000674_ICS_U_M50_600_R_M5_600_W.TAB\n"
"DOA000674_ICS_U_M5_120_R_M50_120_S.TAB\n"
"DOA000674_ICS_U_M5_120_R_M5_120_S.TAB\n"
"DOA000674_ICS_U_M5_600_R_M50_600_W.TAB\n"
"DOA000674_ICS_U_M5_600_R_M5_600_W.TAB\n"
"DOA002372_ICS_U_M10_120_R_M10_120_S_2D.TAB\n"
"DOA002372_ICS_U_M10_600_R_M10_600_W_2D.TAB\n"
"DOA002372_ICS_U_M1_120_R_M1_120_S_2D.TAB\n"
"DOA002372_ICS_U_M1_120_R_M200_120CC_S_2D.TAB\n"
"DOA002372_ICS_U_M1_120_R_M200_120_S_2D.TAB\n"
"DOA002372_ICS_U_M1_120_R_M30_120CC_S_2D.TAB\n"
"DOA002372_ICS_U_M1_600_R_M1_600_W_2D.TAB\n"
"DOA002372_ICS_U_M1_600_R_M200_600CC_W_2D.TAB\n"
"DOA002372_ICS_U_M1_600_R_M200_600_W_2D.TAB\n"
"DOA002372_ICS_U_M1_600_R_M30_600CC_W_2D.TAB\n"
"DOA002372_ICS_U_M200_120CC_R_M1_120_S_2D.TAB\n"
"DOA002372_ICS_U_M200_120_R_M1_120_S_2D.TAB\n"
"DOA002372_ICS_U_M200_600CC_R_M1_600_W_2D.TAB\n"
"DOA002372_ICS_U_M200_600_R_M1_600_W_2D.TAB\n"
"DOA002372_ICS_U_M2_120_R_M2_120_S_2D.TAB\n"
"DOA002372_ICS_U_M2_600_R_M2_600_W_2D.TAB\n"
"DOA002372_ICS_U_M30_120CC_R_M1_120_S_2D.TAB\n"
"DOA002372_ICS_U_M30_600CC_R_M1_600_W_2D.TAB\n"
"DOA002372_ICS_U_M50_120_R_M5_120_S_2D.TAB\n"
"DOA002372_ICS_U_M50_600_R_M5_600_W_2D.TAB\n"
"DOA002372_ICS_U_M5_120_R_M50_120_S_2D.TAB\n"
"DOA002372_ICS_U_M5_120_R_M5_120_S_2D.TAB\n"
"DOA002372_ICS_U_M5_600_R_M50_600_W_2D.TAB\n"
"DOA002372_ICS_U_M5_600_R_M5_600_W_2D.TAB\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.