import Foundation
let pattern = #"\b([0-9]{1,2})\.[0-9]{1,2}\.[0-9]{3,4}[\.]{0,1}[0-9]{0,4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Microsoft SQL Server 2008 (SP1) - 10.0.2531.0 (X64) Mar 29 2009 10:11:52
Copyright (c) 1988-2008 Microsoft Corporation
Express Edition (64-bit) on Windows NT 6.1 <X64> (Build 7600: )
↓SQL Server 2016 – 13.00.900.73 (CTP3.2)
↓SQL Server 2014 12.00.2000.8 12.0.4100.1 12.0.4436.0 (SP1 CU4)
↓SQL Server 2012 11.00.2100.60 11.00.3000 11.00.5058 11.00.6020 11.0.6020 (SP3)
↓SQL Server 2008R2 10.50.1600.1 10.50.2500 10.50.4000 10.50.6000 10.50.6529 (MS15-058)
↓SQL Server 2008 10.00.1600.22 10.00.2531 10.00.4000 10.00.5500 10.00.6000 10.00.6535 (MS15-058)
↓SQL Server 2005 9.00.1399.06 9.00.2047 9.00.3042 9.00.4035 9.00.5000 9.00.5324 (MS12-070)
↓SQL Server 2000 8.00.194 8.00.384 8.00.532 8.00.760 8.00.2039 8.00.2305 (MS12-060)
↓SQL Server 7.0 7.0.623 7.0.699 7.0.842 7.00.961 7.00.1063 7.00.1152 (MS08-040)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)