$re = '/\d+(,\d{1,2})/';
$str = 'einmalig gesamt44,00 €
einmalig gesamt28,00 €';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);