re = /^((?:[A-Za-z0-9#\-_~!$&'()*+,;=:]|[A-Za-z0-9#\-_~!$&'()*+,;=:][A-Za-z0-9#\-_~!$&'()*+,;=:\.]*[A-Za-z0-9#\-_~!$&'()*+,;=:])@(?:[A-Za-z0-9]\.|[A-Za-z0-9][A-Za-z0-9#\-]{0,61}[A-Za-z0-9]\.)+(?:[A-Za-z0-9]|[A-Za-z0-9][A-Za-z0-9#\-]{0,61}[A-Za-z0-9]))\.?$/
str = ' '
# Print the match result
str.match(re) do |match|
puts match.to_s
end