$re = '/(https?:\/\/).*/';
$str = '.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(.../instant/templates/_default_/images/nyromodal/close.gif);
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);