$re = '/^(?![-])(?!.*[-]$)(?!.*[-]{2})[0-9-]+$/m';
$str = '0808080099809080980098098080808080808';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);