re = /\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}/
str = '+79242051818'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end