$re = '/{(\$[a-z0-9]+\.[a-z0-9]+)|(\".*\")}/';
$str = '{{$user.firstName}|{$user.name}|{"amigo"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);