#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((?:http:\/\/+|www\.+|https:\/\/+)(?:\W+|\S+|\s+|.+)(?:\.net+|\.ro+))"
Local $sString = "glass shoes door window door glasses. window glasses sunglasses" & @CRLF & _
"glass" & @CRLF & _
"asdblog" & @CRLF & _
"{www.asdblog.iqads.net}" & @CRLF & _
"{http://creator.iqads.ro/NESCAFE3in1}" & @CRLF & _
"http://twitter.com/share" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/11912.png" & @CRLF & _
"http://cluj.tecomm.ro/" & @CRLF & _
"http://www.godmother.ro" & @CRLF & _
"http://www.facebook.com/godmotherBTL" & @CRLF & _
"http://twitter.com/share" & @CRLF & _
"http://media.iqads.ro/2015/10/rm2hb-cover-400.jpg" & @CRLF & _
"http://media.iqads.ro/2015/09/vv-cover-800-cover-400.jpg" & @CRLF & _
"http://media.iqads.ro/2015/08/razvan-mitoiu-photo-cover-400.jpg" & @CRLF & _
"http://media.iqads.ro/2015/06/dsc7179-cover-400.jpg" & @CRLF & _
"http://media.iqads.ro/2015/05/raluca2-cover-400.jpg" & @CRLF & _
"http://media.iqads.ro/2015/05/1me-cover-400.jpg" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/263355.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/32786.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/22703.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/23589.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/228683.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/23696.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/16968.png" & @CRLF & _
"http://cdn.iqads.ro/photos/tags/263192.png" & @CRLF & _
"http://www.blueidea.ro" & @CRLF & _
"http://www.blueidea.ro"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")