#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(\([\w\s].*[\w\s]\)|\(\)) =>"
Local $sString = "var MODULE = ((my, $, undefined) => {" & @CRLF & _
"" & @CRLF & _
" console.log('EXECUTION FROM LEGACY APP START ===>');" & @CRLF & _
"" & @CRLF & _
" // if private var defined in my module, use that" & @CRLF & _
" // else create a private var" & @CRLF & _
" var _private = my._private = my._private || {}," & @CRLF & _
" _seal = my._seal = function seal(seal) {" & @CRLF & _
" if (!seal) {" & @CRLF & _
" return;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" delete my._private;" & @CRLF & _
" delete my._seal;" & @CRLF & _
" console.log('SEALED');" & @CRLF & _
" }," & @CRLF & _
" _unseal = my._unseal = function unseal(unseal) {" & @CRLF & _
" if (!unseal) {" & @CRLF & _
" return;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" my._seal = _seal;" & @CRLF & _
" my._private = _private;" & @CRLF & _
" console.log('UNSEALED');" & @CRLF & _
" };" & @CRLF & _
"" & @CRLF & _
" var name = 'Tonny Frank';" & @CRLF & _
" _private.name = 'This is a private name: ' + name;" & @CRLF & _
"" & @CRLF & _
" _private.reverse = function reverse(str) {" & @CRLF & _
" return str.split('').reverse().join('');" & @CRLF & _
" };" & @CRLF & _
"" & @CRLF & _
" if ($ === undefined) {" & @CRLF & _
" console.log('jQuery not defined');" & @CRLF & _
" return;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" $(() => {" & @CRLF & _
" var $h1 = $('.card').children('h1');" & @CRLF & _
" $h1.html(_private.reverse($h1.html()));" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
" console.log(my);" & @CRLF & _
" my.myMethod = () => {" & @CRLF & _
" console.log('MODULE myMethod Executed');" & @CRLF & _
" $('.name').html('Abhisek ...');" & @CRLF & _
" $('button').click(function (ev) {" & @CRLF & _
" ev.preventDefault();" & @CRLF & _
" console.log(this);" & @CRLF & _
" $(this).html('Damn!');" & @CRLF & _
" });" & @CRLF & _
" };" & @CRLF & _
"" & @CRLF & _
" console.log('EXECUTION FROM LEGACY APP END <===');" & @CRLF & _
"" & @CRLF & _
" return my;" & @CRLF & _
"})(MODULE || {}, this.jQuery);" & @CRLF & _
""
Local $sSubst = "function $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)