import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\p{InHiragana}+|\\p{InKatakana}+|\\p{IsHan}+]+[県都府道])(.*)";
final String string = "〒100-0001 北海道千代田区千代田1−1−1\n"
+ "青森県\n"
+ "岩手県\n"
+ "宮城県\n"
+ "秋田県\n"
+ "山形県\n"
+ "福島県\n"
+ "茨城県\n"
+ "栃木県\n"
+ "群馬県\n"
+ "埼玉県\n"
+ "千葉県\n"
+ "東京都\n"
+ "神奈川県\n"
+ "新潟県\n"
+ "富山県\n"
+ "石川県\n"
+ "福井県\n"
+ "山梨県\n"
+ "長野県\n"
+ "岐阜県\n"
+ "静岡県\n"
+ "愛知県\n"
+ "三重県\n"
+ "滋賀県\n"
+ "京都府\n"
+ "大阪府\n"
+ "兵庫県\n"
+ "奈良県\n"
+ "和歌山県\n"
+ "鳥取県\n"
+ "島根県\n"
+ "岡山県\n"
+ "広島県\n"
+ "山口県\n"
+ "徳島県\n"
+ "香川県\n"
+ "愛媛県\n"
+ "高知県\n"
+ "福岡県\n"
+ "佐賀県\n"
+ "長崎県\n"
+ "熊本県\n"
+ "大分県\n"
+ "宮崎県\n"
+ "鹿児島県\n"
+ "沖縄県";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}