#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{12,22}\b"
Local $sString = "ESN: 355496930746061, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 35722223989377, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 354553495098527, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 350448885354834, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917263813650, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 351646277216193, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 357883403755026, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917262541195, Shipper:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")