$re = '/(https?:\/\/.*\.(?:png|jpg))/i';
$str = 'http://sub.domain.com/uploads/files/23-11-2011/234552-574-2321-232/asd.png';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);