import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "001,Legislative Branch,00,Legislative Branch,,\"Receipts, Central fiscal operations\",,803,Central fiscal operations,Mandatory,Nongrant,On-budget,-628,-390,-469,-413,-410,-722,-464,-522,-439,-360,-343,-427,-539,-307,-287,-132,-429,-385,-726,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}