package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+)d|\s+|(\d+)h|\s+|(\d+)m`)
var str = `13d 20h 32m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}