re = /^\/(?!.*\/\/)([a-zA-Z-\/]+)$/im
str = '/this/is/an/url/path
/this/is/an/url/path/
/this/is/an/url/path!
/this/is/an/url/path@
/this-is-an//url/path'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end