#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/\/.*| ?\/\*[^]*?\*\/)(,?)$"
Local $sString = "/**" & @CRLF & _
" * " & @CRLF & _
" * " & @CRLF & _
" * a multi-line example just for fun" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" "compilerOptions": {" & @CRLF & _
" /* Visit https://aka.ms/tsconfig.json to read more about this file */" & @CRLF & _
"" & @CRLF & _
" /* Basic Options */" & @CRLF & _
" // "incremental": true, /* Enable incremental compilation */" & @CRLF & _
" "target": "ES6" /* Specify ECMAScript target version: 'ES3' (default), 'ES5', 'ES2015', 'ES2016', 'ES2017', 'ES2018', 'ES2019', 'ES2020', or 'ESNEXT'. */," & @CRLF & _
" "module": "commonjs" /* Specify module code generation: 'none', 'commonjs', 'amd', 'system', 'umd', 'es2015', 'es2020', or 'ESNext'. */," & @CRLF & _
" "lib": ["dom", "es6"] /* Specify library files to be included in the compilation. */," & @CRLF & _
" "allowJs": true /* Allow javascript files to be compiled. */," & @CRLF & _
" // "checkJs": true, /* Report errors in .js files. */" & @CRLF & _
" // "jsx": "preserve", /* Specify JSX code generation: 'preserve', 'react-native', or 'react'. */" & @CRLF & _
" "declaration": true /* Generates corresponding '.d.ts' file. */," & @CRLF & _
" "declarationMap": true /* Generates a sourcemap for each corresponding '.d.ts' file. */," & @CRLF & _
" // "sourceMap": true, /* Generates corresponding '.map' file. */" & @CRLF & _
" // "outFile": "./", /* Concatenate and emit output to single file. */" & @CRLF & _
" // "outDir": "./dist" /* Redirect output structure to the directory. */," & @CRLF & _
" // "rootDir": "./", /* Specify the root directory of input files. Use to control the output directory structure with --outDir. */" & @CRLF & _
" // "composite": true, /* Enable project compilation */" & @CRLF & _
" // "tsBuildInfoFile": "./", /* Specify file to store incremental compilation information */" & @CRLF & _
" // "removeComments": true, /* Do not emit comments to output. */" & @CRLF & _
" // "noEmit": true, /* Do not emit outputs. */" & @CRLF & _
" // "importHelpers": true, /* Import emit helpers from 'tslib'. */" & @CRLF & _
" // "downlevelIteration": true, /* Provide full support for iterables in 'for-of', spread, and destructuring when targeting 'ES5' or 'ES3'. */" & @CRLF & _
" // "isolatedModules": true, /* Transpile each file as a separate module (similar to 'ts.transpileModule'). */" & @CRLF & _
"" & @CRLF & _
" /* Strict Type-Checking Options */" & @CRLF & _
" "strict": true /* Enable all strict type-checking options. */," & @CRLF & _
" // "noImplicitAny": true, /* Raise error on expressions and declarations with an implied 'any' type. */" & @CRLF & _
" // "strictNullChecks": true, /* Enable strict null checks. */" & @CRLF & _
" // "strictFunctionTypes": true, /* Enable strict checking of function types. */" & @CRLF & _
" // "strictBindCallApply": true, /* Enable strict 'bind', 'call', and 'apply' methods on functions. */" & @CRLF & _
" // "strictPropertyInitialization": true, /* Enable strict checking of property initialization in classes. */" & @CRLF & _
" // "noImplicitThis": true, /* Raise error on 'this' expressions with an implied 'any' type. */" & @CRLF & _
" // "alwaysStrict": true, /* Parse in strict mode and emit "use strict" for each source file. */" & @CRLF & _
"" & @CRLF & _
" /* Additional Checks */" & @CRLF & _
" // "noUnusedLocals": true, /* Report errors on unused locals. */" & @CRLF & _
" // "noUnusedParameters": true, /* Report errors on unused parameters. */" & @CRLF & _
" // "noImplicitReturns": true, /* Report error when not all code paths in function return a value. */" & @CRLF & _
" // "noFallthroughCasesInSwitch": true, /* Report errors for fallthrough cases in switch statement. */" & @CRLF & _
"" & @CRLF & _
" /* Module Resolution Options */" & @CRLF & _
" // "moduleResolution": "node", /* Specify module resolution strategy: 'node' (Node.js) or 'classic' (TypeScript pre-1.6). */" & @CRLF & _
" "baseUrl": "./" /* Base directory to resolve non-absolute module names. */," & @CRLF & _
" "paths": {" & @CRLF & _
" /* A series of entries which re-map imports to lookup locations relative to the 'baseUrl'. */" & @CRLF & _
" /* TODO: Fix alias resolution with cypress */" & @CRLF & _
" "@lib": ["cypress/lib"]," & @CRLF & _
" "@lib/*": ["cypress/lib/*"]," & @CRLF & _
" "@log/browser": ["cypress/support/customCommands/browserLog"]," & @CRLF & _
" "@log/node": ["cypress/lib/nodeLog"]," & @CRLF & _
" "@tasks": ["cypress/plugins/tasks"]," & @CRLF & _
" "@tasks/*": ["cypress/plugins/tasks/*"]" & @CRLF & _
" }," & @CRLF & _
" // "rootDirs": [], /* List of root folders whose combined content represents the structure of the project at runtime. */" & @CRLF & _
" // "typeRoots": [], /* List of folders to include type definitions from. */" & @CRLF & _
" "types": ["node", "cypress", "./types"] /* Type declaration files to be included in compilation. */," & @CRLF & _
" // "allowSyntheticDefaultImports": true, /* Allow default imports from modules with no default export. This does not affect code emit, just typechecking. */" & @CRLF & _
" "esModuleInterop": true /* Enables emit interoperability between CommonJS and ES Modules via creation of namespace objects for all imports. Implies 'allowSyntheticDefaultImports'. */," & @CRLF & _
" // "preserveSymlinks": true, /* Do not resolve the real path of symlinks. */" & @CRLF & _
" // "allowUmdGlobalAccess": true, /* Allow accessing UMD globals from modules. */" & @CRLF & _
"" & @CRLF & _
" /* Source Map Options */" & @CRLF & _
" // "sourceRoot": "", /* Specify the location where debugger should locate TypeScript files instead of source locations. */" & @CRLF & _
" // "mapRoot": "", /* Specify the location where debugger should locate map files instead of generated locations. */" & @CRLF & _
" // "inlineSourceMap": true, /* Emit a single file with source maps instead of having a separate file. */" & @CRLF & _
" // "inlineSources": true, /* Emit the source alongside the sourcemaps within a single file; requires '--inlineSourceMap' or '--sourceMap' to be set. */" & @CRLF & _
"" & @CRLF & _
" /* Experimental Options */" & @CRLF & _
" // "experimentalDecorators": true, /* Enables experimental support for ES7 decorators. */" & @CRLF & _
" // "emitDecoratorMetadata": true, /* Enables experimental support for emitting type metadata for decorators. */" & @CRLF & _
"" & @CRLF & _
" /* Advanced Options */" & @CRLF & _
" "skipLibCheck": true /* Skip type checking of declaration files. */," & @CRLF & _
" "forceConsistentCasingInFileNames": true /* Disallow inconsistently-cased references to the same file. */," & @CRLF & _
" "resolveJsonModule": true," & @CRLF & _
" "noEmit": true // We should not be using transpiled code at all. We only need to run tsc to ensure type checking!" & @CRLF & _
" }," & @CRLF & _
" "include": ["cypress/**/*.ts", "npm-scripts/**/*.ts", "ops/**/*.ts", "cypress.json", "cypressRunner.ts", "customBootstrapCommand.ts"]," & @CRLF & _
" "exclude": ["**/*.ignore.*", "**/*ignore*/*", "build", "dist", "node_modules"]" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)