#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!021|031)\d*"
Local $sString = "022 123-456-2322" & @CRLF & _
"021 123-456-2322" & @CRLF & _
"031 123-456-2377" & @CRLF & _
"041 123-456-2322" & @CRLF & _
"021 555-456-2322" & @CRLF & _
"031 555-456-2322" & @CRLF & _
"0341 555-456-2322" & @CRLF & _
"021 123-456-2377" & @CRLF & _
"0341 123-456-2377" & @CRLF & _
"0341 123-021-2377" & @CRLF & _
"0341 123-031-2377"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")