#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?i)(?!.*@text.*$).+"
Local $sString = "Text with foo here" & @CRLF & _
"foo Text" & @CRLF & _
"More foo" & @CRLF & _
"@super" & @CRLF & _
"" & @CRLF & _
"@text" & @CRLF & _
"" & @CRLF & _
"Match this line" & @CRLF & _
"" & @CRLF & _
"this seems to work" & @CRLF & _
"as does this with foo " & @CRLF & _
"foofff" & @CRLF & _
"ffffoO" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")