$re = '/INIT \d{3}-\d{3}-\d{3}-\d{3}/m';
$str = 'INIT 255-255-255-255';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);