using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https:\/\/provider.sharespaceapp.swisscom.com((?!:(443|80)(($)|(\/))))(?:(?:(?::)(\d*)))?(?:(?:(\/latest)(?=\/))|(?:(\/latest)($)))?)";
string input = @"https://provider.sharespaceapp.swisscom.com:44303/latest/scripts/sharespace.js";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}