$re = '/s,(^[0-9]+.(?:[0-9]+)+\;+)+|(^[0-9]+.\;)+/';
$str = '900100003,;900100007,;900100111,;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);